WebTest Presenter Plugin

Plugin Information

Plugin ID webtestpresenter
Latest Release 0.23
Latest Release Date Jan 15, 2010
Sources Subversion
Support Eclipse Hudson Forum
Issue Tracking Eclipse Bugzilla

This plugin publishes the reports generated by the Canoo WebTest tool for each build.
Note: the webtestpresenter plugin has only been tested with free-style project projects.

Description

This plugin simply publishes the reports generated by the Canoo WebTest tool http://webtest.canoo.com. It is assumed that the webtests are run during the build process. If the build succeeds, this plugin will then create a link to the Webtests from the build page.

Configuration

Configuration is rather straightforward: simply indicate where the Webtest results are placed by your build process: 
When a build has successfully run and the Webtest results have been generated, the plugin will create a link to the Webtest results in the build results page:

 

Clicking on the "Webtest Results" link will take you to the standard Canoo WebTests report pages.

Notes

If you wish to integrate the Webtest results into the standard "Test Result" charting, you will need to use Webtest version R_1657 or newer, which produces an overview report in junit-report format (WebTestOverview.junit.xml) that the junit report publisher can parse. However, this report currently only contains information on whether tests passed or failed, and how long the tests took. Therefore, this method is most useful in tracking test pass/fail trends, and can be useful when used in conjunction with the webtestpresenter plugin.

Version History

Version 0.23 (Jan 16 2010)

  • Update code for more recent Hudson.. requires Hudson 1.319 or newer.

Version 0.22 (Jul 14 2008)

Version 0.21 (Mar 16 2008)

  • Initial release.

Labels:

plugin-report plugin-report Delete
Enter labels to add to this page:
Wait Image 
Looking for a label? Just start typing.
  1. May 09, 2008

    Tom Larrow says:

    This plugin has been very helpful for us, however I have noticed a few oddities....

    This plugin has been very helpful for us, however I have noticed a few oddities.

    Since installing this plugin, the Webtest result is now considered an "Build Artifact" and included in the build artifact screen.   Before this simply showed our .ear file that had been deployed.  Now we have to drill down through the file structure to find the .ear. or choose to download the zip file that contains both the .ear and the webtest.  It would be great if the webtest did not show up as an artifact.

    Secondly if a build fails, the option to view the webtest is not available.  The only way to view it is to drill down through the workspace, and view the actual webtest .html file.  This causes a problem especially when it is the webtest fails, and that causes the build to fail.  When this happens the next build causes the workspace to be re-built, and you have lost the old webtest results.  You're left with a build that failed, and no webtests that show WHY it failed.

    1. Sep 18, 2008

      Adam Ambrose says:

      Issue 2067 should cover these problems, and version 0.22 was meant to fix them.

      Issue 2067 should cover these problems, and version 0.22 was meant to fix them.

  2. Dec 03, 2008

    martin choma says:

    I try to use it (in version 0.22) with hudson in version 1.262, but didn't work ...

    I try to use it (in version 0.22) with hudson in version 1.262, but didn't work for me. In "Configure" section by clicking on help icon I get screen 404. (see attach)

    When job is finished results are copied correctly, but  clicking on Webtest Results navigates again to screen 404 - like last part of URL "WebTestReport.html" was missing.

    What could be problem - incompatible versions? or am I setting plugin in wrong way? 

     

  3. Apr 07, 2009

    Manlio Reisoli says:

    I'm using 0.22 version of the plugin on Hudson 1.295. OS is Win 2k. If I have c...

    I'm using 0.22 version of the plugin on Hudson 1.295. OS is Win 2k.
    If I have correctly understood the plugin should copy the results of the web test executed after a build (that are saved in the folder in the workspace that contains all web test files) in the related job folder. During this process, though, it misses to copy the resources folder and the folder associated with each test. As a result images, stylesheet and the "resulting pages" are not visible.
    Canoo Web Test is version 3.0 (R_1758).
    Am I doing something wrong?

    1. Apr 09, 2009

      Manlio Reisoli says:

      Yes, I was doing something wrong: I was not running the tests as part of the bui...

      Yes, I was doing something wrong: I was not running the tests as part of the build process but as a post-build task. After moving the web tests inside the build process the reports are correctly published.

  4. Dec 16, 2009

    Andrea Salicetti says:

    Is this project still maintained? I'm using Hudson 1.337 (the latest until toda...

    Is this project still maintained?

    I'm using Hudson 1.337 (the latest until today) with this plugin (v.0.22 - the latest) and run test with CanooWebTest v.3.0 (latest too).

    Same problem as Manilo, but his solution didn't work for me.